Change naming conventions to more inclusive terms. For example "slaveDelay" to "workerDelay" or "rs.isMaster" to "rs.isMain"
There is an initiative in the tech community to replace non-inclusive terms with more inclusive ones and I'd like to get the community's take on it. I think the biggest offenders are terminology referring to "slaves" and "masters", but I'm sure there are others that might fall into that category. Although I'm sure nobody meant any harm by using these terms, I think we can and should do better.
I'm currently working my way through the m103 replication course and I see in replication configuring there's a term "slaveDelay". Also a "rs.isMaster()" method. I'm suggesting replacing "slave" with "worker" and "master" with "main". I know these changes have a gigantic impact logistically speaking, but I think it's time to prioritize the human impact.
An initiative like this ties into a larger movement across the tech industry to create a better, more professional workplace for everyone. See this article for a similar initiative taken on by GitHub: https://www.zdnet.com/article/github-to-replace-master-with-main-starting-next-month/#:~:text=By%20default%2C%20GitHub%20uses%20the,of%20a%20source%20code%20repository.&text=1%2C%202020%2C%20any%20new%20repositories,will%20be%20left%20as%20is.
Most of these terms are deprecated and exist only for backward compatibility. For example 'db.isMaster()' is already replaced by 'db.hello()isWritablePrimary' or 'slaveDelay' became 'secondaryDelaySecs'
AdminMassimiliano (Admin, MongoDB) commented
Thank you for bringing that up.
We are actually in the process to remove all offensive terminology from all products.
The new MongoDB Shell currently still includes isMaster() for backwards compatibility as it's probably one of the most used commands. However, the new command to do the same thing is db.hello()/rs.hello().
Properties like slaveDelay will be gone from the server response too.